const regex = /(\d)()(?=(\d{3})+(?!\d))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d)()(?=(\\d{3})+(?!\\d))', 'g')
const str = `25
321
54500
78545515201`;
const subst = `$1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);