import Foundation
let pattern = #"(\d)()(?=(\d{3})+(?!\d))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
25
321
54500
78545515201
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)