$re = '/(\d)()(?=(\d{3})+(?!\d))/';
$str = '25
321
54500
78545515201';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;