re = /(\d)()(?=(\d{3})+(?!\d))/
str = '25
321
54500
78545515201'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result