using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d)()(?=(\d{3})+(?!\d))";
string substitution = @"$1 $2";
string input = @"25
321
54500
78545515201";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}