import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\\bKeyWord2\\b)|\\G.*?\\K\\bKEYWORD1\\b";
final String string = "The KeyWord2 before one KEYWORD1 here\n"
+ "The KEYWORD1 before one KeyWord2 here\n"
+ "The KEYWORD1 before KeyWord2 then KEYWORD1 and KEYWORD1 again\n"
+ "The KeyWord2 before KEYWORD1 and KEYWORD1 again\n"
+ "The KEYWORD1 before one KeyWord99 here\n"
+ "The KEYWRD before one KeyWord2 here\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}