use strict;
my $str = 'The KeyWord2 before one KEYWORD1 here
The KEYWORD1 before one KeyWord2 here
The KEYWORD1 before KeyWord2 then KEYWORD1 and KEYWORD1 again
The KeyWord2 before KEYWORD1 and KEYWORD1 again
The KEYWORD1 before one KeyWord99 here
The KEYWRD before one KeyWord2 here
';
my $regex = qr/^(?=.*\bKeyWord2\b)|\G.*?\K\bKEYWORD1\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}