import Foundation
let pattern = #"^(?=.*\bKeyWord2\b)|\G.*?\K\bKEYWORD1\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
The KeyWord2 before one KEYWORD1 here
The KEYWORD1 before one KeyWord2 here
The KEYWORD1 before KeyWord2 then KEYWORD1 and KEYWORD1 again
The KeyWord2 before KEYWORD1 and KEYWORD1 again
The KEYWORD1 before one KeyWord99 here
The KEYWRD before one KeyWord2 here
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)