const regex = /^(?=.*\bKeyWord2\b)|\G.*?\K\bKEYWORD1\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*\\bKeyWord2\\b)|\\G.*?\\K\\bKEYWORD1\\b', 'gm')
const str = `The KeyWord2 before one KEYWORD1 here
The KEYWORD1 before one KeyWord2 here
The KEYWORD1 before KeyWord2 then KEYWORD1 and KEYWORD1 again
The KeyWord2 before KEYWORD1 and KEYWORD1 again
The KEYWORD1 before one KeyWord99 here
The KEYWRD before one KeyWord2 here
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}