#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*^(\S*):(\d+):(\d+):.*\n(.*)."
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/path/to/file.hs:86:22: warning: [-Wname-shadowing]" & @CRLF & _
" This binding for ‘myvar’ shadows the existing binding" & @CRLF & _
" imported from ‘My.Module’ at /path/to/file.hs:29:1-30" & @CRLF & _
" (and originally defined" & @CRLF & _
" at /path/to/file.hs:347:1-5)" & @CRLF & _
" " & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")