re = /.*^(\S*):(\d+):(\d+):.*\n(.*)./m
str = '
/path/to/file.hs:86:22: warning: [-Wname-shadowing]
This binding for ‘myvar’ shadows the existing binding
imported from ‘My.Module’ at /path/to/file.hs:29:1-30
(and originally defined
at /path/to/file.hs:347:1-5)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end