import Foundation
let pattern = #".*^(\S*):(\d+):(\d+):.*\n(.*)."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/path/to/file.hs:86:22: warning: [-Wname-shadowing]
This binding for ‘myvar’ shadows the existing binding
imported from ‘My.Module’ at /path/to/file.hs:29:1-30
(and originally defined
at /path/to/file.hs:347:1-5)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)