package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*^(\S*):(\d+):(\d+):.*\n(.*).`)
var str = `
/path/to/file.hs:86:22: warning: [-Wname-shadowing]
This binding for ‘myvar’ shadows the existing binding
imported from ‘My.Module’ at /path/to/file.hs:29:1-30
(and originally defined
at /path/to/file.hs:347:1-5)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}