// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*^(\S*):(\d+):(\d+):.*\n(.*).").unwrap();
let string = "
/path/to/file.hs:86:22: warning: [-Wname-shadowing]
This binding for ‘myvar’ shadows the existing binding
imported from ‘My.Module’ at /path/to/file.hs:29:1-30
(and originally defined
at /path/to/file.hs:347:1-5)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}