using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*^(\S*):(\d+):(\d+):.*\n(.*).";
string input = @"
/path/to/file.hs:86:22: warning: [-Wname-shadowing]
This binding for ‘myvar’ shadows the existing binding
imported from ‘My.Module’ at /path/to/file.hs:29:1-30
(and originally defined
at /path/to/file.hs:347:1-5)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}