import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*^(\\S*):(\\d+):(\\d+):.*\\n(.*).";
final String string = "\n\n\n"
+ "/path/to/file.hs:86:22: warning: [-Wname-shadowing]\n"
+ " This binding for ‘myvar’ shadows the existing binding\n"
+ " imported from ‘My.Module’ at /path/to/file.hs:29:1-30\n"
+ " (and originally defined\n"
+ " at /path/to/file.hs:347:1-5)\n"
+ " \n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}