use strict;
my $str = '
/path/to/file.hs:86:22: warning: [-Wname-shadowing]
This binding for ‘myvar’ shadows the existing binding
imported from ‘My.Module’ at /path/to/file.hs:29:1-30
(and originally defined
at /path/to/file.hs:347:1-5)
';
my $regex = qr/.*^(\S*):(\d+):(\d+):.*\n(.*)./mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}