# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=:90C:|:90D:)(.*?)ABC(\S+)/$1XYZ$2/gm;t' <<< " :20: LAIDKZPABCL90165LZJABC
:90: LZ,90509LAOABCXL,XKPA;AOLZ
:90C: KDOLASABC9080690ABD
:90D: ABDBABC906AODIPALKD
:90L: AND9011112XXXADABC
:90: AKLZPDOAMXNA,;POAS"