# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=:90C:|:90D:)(.*?)ABC(\S+)"
test_str = (" :20: LAIDKZPABCL90165LZJABC\n"
" :90: LZ,90509LAOABCXL,XKPA;AOLZ\n"
" :90C: KDOLASABC9080690ABD\n"
" :90D: ABDBABC906AODIPALKD\n"
" :90L: AND9011112XXXADABC\n"
" :90: AKLZPDOAMXNA,;POAS")
subst = "$1XYZ$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.