$re = '/(?=:90C:|:90D:)(.*?)ABC(\S+)/m';
$str = ' :20: LAIDKZPABCL90165LZJABC
:90: LZ,90509LAOABCXL,XKPA;AOLZ
:90C: KDOLASABC9080690ABD
:90D: ABDBABC906AODIPALKD
:90L: AND9011112XXXADABC
:90: AKLZPDOAMXNA,;POAS';
$subst = "$1XYZ$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;