const regex = /(?=:90C:|:90D:)(.*?)ABC(\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=:90C:|:90D:)(.*?)ABC(\\S+)', 'gm')
const str = ` :20: LAIDKZPABCL90165LZJABC
:90: LZ,90509LAOABCXL,XKPA;AOLZ
:90C: KDOLASABC9080690ABD
:90D: ABDBABC906AODIPALKD
:90L: AND9011112XXXADABC
:90: AKLZPDOAMXNA,;POAS`;
const subst = `$1XYZ$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);