#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=:90C:|:90D:)(.*?)ABC(\S+)"
Local $sString = " :20: LAIDKZPABCL90165LZJABC" & @CRLF & _
" :90: LZ,90509LAOABCXL,XKPA;AOLZ" & @CRLF & _
" :90C: KDOLASABC9080690ABD" & @CRLF & _
" :90D: ABDBABC906AODIPALKD" & @CRLF & _
" :90L: AND9011112XXXADABC" & @CRLF & _
" :90: AKLZPDOAMXNA,;POAS"
Local $sSubst = "$1XYZ$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)