import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=:90C:|:90D:)(.*?)ABC(\\S+)";
final String string = " :20: LAIDKZPABCL90165LZJABC\n"
+ " :90: LZ,90509LAOABCXL,XKPA;AOLZ\n"
+ " :90C: KDOLASABC9080690ABD\n"
+ " :90D: ABDBABC906AODIPALKD\n"
+ " :90L: AND9011112XXXADABC\n"
+ " :90: AKLZPDOAMXNA,;POAS";
final String subst = "$1XYZ$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}