import Foundation
let pattern = #"(?=:90C:|:90D:)(.*?)ABC(\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
:20: LAIDKZPABCL90165LZJABC
:90: LZ,90509LAOABCXL,XKPA;AOLZ
:90C: KDOLASABC9080690ABD
:90D: ABDBABC906AODIPALKD
:90L: AND9011112XXXADABC
:90: AKLZPDOAMXNA,;POAS
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1XYZ$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)