use strict;
my $str = ' :20: LAIDKZPABCL90165LZJABC
:90: LZ,90509LAOABCXL,XKPA;AOLZ
:90C: KDOLASABC9080690ABD
:90D: ABDBABC906AODIPALKD
:90L: AND9011112XXXADABC
:90: AKLZPDOAMXNA,;POAS';
my $regex = qr/(?=:90C:|:90D:)(.*?)ABC(\S+)/mp;
my $subst = '$1XYZ$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";