# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n\s{0,3}<.*[^>]+|<sub>.*?<\\/sub>|`.*?`//gm;t' <<< "something1
<sub>
something2
<div class='myclass'>something3</div>
</sub>
<div class='myclass'>something4</div>
something5
<div class='myclass'>something6</div>
<div class='myclass'>something7</div>
`<div>something8</div>`
something9"