package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\n\s{0,3}<.*[^>]+|<sub>.*?<\/sub>|`.*?``)
var str = `something1
<sub>
something2
<div class='myclass'>something3</div>
</sub>
<div class='myclass'>something4</div>
something5
<div class='myclass'>something6</div>
<div class='myclass'>something7</div>
\`<div>something8</div>\`
something9`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}