// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\n\s{0,3}<.*[^>]+|<sub>.*?<\/sub>|`.*?`").unwrap();
let string = "something1
<sub>
something2
<div class='myclass'>something3</div>
</sub>
<div class='myclass'>something4</div>
something5
<div class='myclass'>something6</div>
<div class='myclass'>something7</div>
`<div>something8</div>`
something9";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}