#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\n\s{0,3}<.*[^>]+|<sub>.*?<\/sub>|`.*?`"
Local $sString = "something1" & @CRLF & _
"<sub>" & @CRLF & _
" something2" & @CRLF & _
" <div class='myclass'>something3</div>" & @CRLF & _
"</sub>" & @CRLF & _
"<div class='myclass'>something4</div>" & @CRLF & _
"something5" & @CRLF & _
"" & @CRLF & _
" <div class='myclass'>something6</div>" & @CRLF & _
"<div class='myclass'>something7</div>" & @CRLF & _
"`<div>something8</div>`" & @CRLF & _
"something9"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)