use strict;
my $str = 'something1
<sub>
something2
<div class=\'myclass\'>something3</div>
</sub>
<div class=\'myclass\'>something4</div>
something5
<div class=\'myclass\'>something6</div>
<div class=\'myclass\'>something7</div>
`<div>something8</div>`
something9';
my $regex = qr/\n\s{0,3}<.*[^>]+|<sub>.*?<\/sub>|`.*?`/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";