using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n\s{0,3}<.*[^>]+|<sub>.*?<\/sub>|`.*?`";
string substitution = @"";
string input = @"something1
<sub>
something2
<div class='myclass'>something3</div>
</sub>
<div class='myclass'>something4</div>
something5
<div class='myclass'>something6</div>
<div class='myclass'>something7</div>
`<div>something8</div>`
something9";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}