# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\n\s{0,3}<.*[^>]+|<sub>.*?<\/sub>|`.*?`"
test_str = ("something1\n"
"<sub>\n"
" something2\n"
" <div class='myclass'>something3</div>\n"
"</sub>\n"
"<div class='myclass'>something4</div>\n"
"something5\n\n"
" <div class='myclass'>something6</div>\n"
"<div class='myclass'>something7</div>\n"
"`<div>something8</div>`\n"
"something9")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.