#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a href="\/Public\/Details\/(.+?)\?OID=(.+?)" .*?>.*?<\/a>\s*<\/td><td>\s*<img.*?\/>\s*<\/td><td.*?>\s*(?:[^\s0]|[^\s]{2,})?\s*<\/td>"
Local $sString = "<a href="/Public/Details/06S?OID=2" title="Click to view details">06S</a>" & @CRLF & _
" </td><td>" & @CRLF & _
" <img src="/Media/Images/Opr/2.png" title="Pa" />" & @CRLF & _
" </td><td style="0">" & @CRLF & _
" 03" & @CRLF & _
" </td>" & @CRLF & _
"" & @CRLF & _
"<a href="/Public/Details/06S?OID=2" title="Click to view details">06S</a>" & @CRLF & _
" </td><td>" & @CRLF & _
" <img src="/Media/Images/Opr/2.png" title="Pa" />" & @CRLF & _
" </td><td style="0">" & @CRLF & _
" 4" & @CRLF & _
" </td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")