import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a href=\"\\/Public\\/Details\\/(.+?)\\?OID=(.+?)\" .*?>.*?<\\/a>\\s*<\\/td><td>\\s*<img.*?\\/>\\s*<\\/td><td.*?>\\s*(?:[^\\s0]|[^\\s]{2,})?\\s*<\\/td>";
final String string = "<a href=\"/Public/Details/06S?OID=2\" title=\"Click to view details\">06S</a>\n"
+ " </td><td>\n"
+ " <img src=\"/Media/Images/Opr/2.png\" title=\"Pa\" />\n"
+ " </td><td style=\"0\">\n"
+ " 03\n"
+ " </td>\n\n"
+ "<a href=\"/Public/Details/06S?OID=2\" title=\"Click to view details\">06S</a>\n"
+ " </td><td>\n"
+ " <img src=\"/Media/Images/Opr/2.png\" title=\"Pa\" />\n"
+ " </td><td style=\"0\">\n"
+ " 4\n"
+ " </td>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}