using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href=""\/Public\/Details\/(.+?)\?OID=(.+?)"" .*?>.*?<\/a>\s*<\/td><td>\s*<img.*?\/>\s*<\/td><td.*?>\s*(?:[^\s0]|[^\s]{2,})?\s*<\/td>";
string input = @"<a href=""/Public/Details/06S?OID=2"" title=""Click to view details"">06S</a>
</td><td>
<img src=""/Media/Images/Opr/2.png"" title=""Pa"" />
</td><td style=""0"">
03
</td>
<a href=""/Public/Details/06S?OID=2"" title=""Click to view details"">06S</a>
</td><td>
<img src=""/Media/Images/Opr/2.png"" title=""Pa"" />
</td><td style=""0"">
4
</td>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}