// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a href="\/Public\/Details\/(.+?)\?OID=(.+?)" .*?>.*?<\/a>\s*<\/td><td>\s*<img.*?\/>\s*<\/td><td.*?>\s*(?:[^\s0]|[^\s]{2,})?\s*<\/td>"#).unwrap();
let string = "<a href=\"/Public/Details/06S?OID=2\" title=\"Click to view details\">06S</a>
</td><td>
<img src=\"/Media/Images/Opr/2.png\" title=\"Pa\" />
</td><td style=\"0\">
03
</td>
<a href=\"/Public/Details/06S?OID=2\" title=\"Click to view details\">06S</a>
</td><td>
<img src=\"/Media/Images/Opr/2.png\" title=\"Pa\" />
</td><td style=\"0\">
4
</td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}