$re = '/<a href="\/Public\/Details\/(.+?)\?OID=(.+?)" .*?>.*?<\/a>\s*<\/td><td>\s*<img.*?\/>\s*<\/td><td.*?>\s*(?:[^\s0]|[^\s]{2,})?\s*<\/td>/';
$str = '<a href="/Public/Details/06S?OID=2" title="Click to view details">06S</a>
</td><td>
<img src="/Media/Images/Opr/2.png" title="Pa" />
</td><td style="0">
03
</td>
<a href="/Public/Details/06S?OID=2" title="Click to view details">06S</a>
</td><td>
<img src="/Media/Images/Opr/2.png" title="Pa" />
</td><td style="0">
4
</td>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);