import re
regex = re.compile(r"<a href=\"\/Public\/Details\/(.+?)\?OID=(.+?)\" .*?>.*?<\/a>\s*<\/td><td>\s*<img.*?\/>\s*<\/td><td.*?>\s*(?:[^\s0]|[^\s]{2,})?\s*<\/td>")
test_str = ("<a href=\"/Public/Details/06S?OID=2\" title=\"Click to view details\">06S</a>\n"
" </td><td>\n"
" <img src=\"/Media/Images/Opr/2.png\" title=\"Pa\" />\n"
" </td><td style=\"0\">\n"
" 03\n"
" </td>\n\n"
"<a href=\"/Public/Details/06S?OID=2\" title=\"Click to view details\">06S</a>\n"
" </td><td>\n"
" <img src=\"/Media/Images/Opr/2.png\" title=\"Pa\" />\n"
" </td><td style=\"0\">\n"
" 4\n"
" </td>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")