package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a href="\/Public\/Details\/(.+?)\?OID=(.+?)" .*?>.*?<\/a>\s*<\/td><td>\s*<img.*?\/>\s*<\/td><td.*?>\s*(?:[^\s0]|[^\s]{2,})?\s*<\/td>`)
var str = `<a href="/Public/Details/06S?OID=2" title="Click to view details">06S</a>
</td><td>
<img src="/Media/Images/Opr/2.png" title="Pa" />
</td><td style="0">
03
</td>
<a href="/Public/Details/06S?OID=2" title="Click to view details">06S</a>
</td><td>
<img src="/Media/Images/Opr/2.png" title="Pa" />
</td><td style="0">
4
</td>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}