const regex = /<a href="\/Public\/Details\/(.+?)\?OID=(.+?)" .*?>.*?<\/a>\s*<\/td><td>\s*<img.*?\/>\s*<\/td><td.*?>\s*(?:[^\s0]|[^\s]{2,})?\s*<\/td>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a href="\\\/Public\\\/Details\\\/(.+?)\\?OID=(.+?)" .*?>.*?<\\\/a>\\s*<\\\/td><td>\\s*<img.*?\\\/>\\s*<\\\/td><td.*?>\\s*(?:[^\\s0]|[^\\s]{2,})?\\s*<\\\/td>', 'g')
const str = `<a href="/Public/Details/06S?OID=2" title="Click to view details">06S</a>
</td><td>
<img src="/Media/Images/Opr/2.png" title="Pa" />
</td><td style="0">
03
</td>
<a href="/Public/Details/06S?OID=2" title="Click to view details">06S</a>
</td><td>
<img src="/Media/Images/Opr/2.png" title="Pa" />
</td><td style="0">
4
</td>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}