#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<=#region VARIAVEIS GLOBAIS).*?(?=#endregion)"
Local $sString = "#region VARIAVEIS GLOBAIS" & @CRLF & _
"string aux1 = "teste";" & @CRLF & _
"string aux2 = "teste2";" & @CRLF & _
"string aux3 = "teste3";" & @CRLF & _
"string aux4 = "teste4";" & @CRLF & _
"string aux5 = "teste5";" & @CRLF & _
"#endregion"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")