const regex = /(?<=#region VARIAVEIS GLOBAIS).*?(?=#endregion)/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=#region VARIAVEIS GLOBAIS).*?(?=#endregion)', 's')
const str = `#region VARIAVEIS GLOBAIS
string aux1 = "teste";
string aux2 = "teste2";
string aux3 = "teste3";
string aux4 = "teste4";
string aux5 = "teste5";
#endregion`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}