import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=#region VARIAVEIS GLOBAIS).*?(?=#endregion)";
final String string = "#region VARIAVEIS GLOBAIS\n"
+ "string aux1 = \"teste\";\n"
+ "string aux2 = \"teste2\";\n"
+ "string aux3 = \"teste3\";\n"
+ "string aux4 = \"teste4\";\n"
+ "string aux5 = \"teste5\";\n"
+ "#endregion";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}