$re = '/(?<=#region VARIAVEIS GLOBAIS).*?(?=#endregion)/s';
$str = '#region VARIAVEIS GLOBAIS
string aux1 = "teste";
string aux2 = "teste2";
string aux3 = "teste3";
string aux4 = "teste4";
string aux5 = "teste5";
#endregion';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);