re = /(?<=#region VARIAVEIS GLOBAIS).*?(?=#endregion)/
str = '#region VARIAVEIS GLOBAIS
string aux1 = "teste";
string aux2 = "teste2";
string aux3 = "teste3";
string aux4 = "teste4";
string aux5 = "teste5";
#endregion'
# Print the match result
str.match(re) do |match|
puts match.to_s
end