import re
regex = re.compile(r"(?<=#region VARIAVEIS GLOBAIS).*?(?=#endregion)", flags=re.DOTALL)
test_str = ("#region VARIAVEIS GLOBAIS\n"
"string aux1 = \"teste\";\n"
"string aux2 = \"teste2\";\n"
"string aux3 = \"teste3\";\n"
"string aux4 = \"teste4\";\n"
"string aux5 = \"teste5\";\n"
"#endregion")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")