import Foundation
let pattern = ##"(?<=#region VARIAVEIS GLOBAIS).*?(?=#endregion)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = ##"""
#region VARIAVEIS GLOBAIS
string aux1 = "teste";
string aux2 = "teste2";
string aux3 = "teste3";
string aux4 = "teste4";
string aux5 = "teste5";
#endregion
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}