#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)problem path:.+"
Local $sString = "here is one line" & @CRLF & _
"problem path: path1" & @CRLF & _
"another line" & @CRLF & _
"value line more info" & @CRLF & _
"value" & @CRLF & _
"problem path: path2" & @CRLF & _
"incredible data line" & @CRLF & _
"problem path: path3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")