const regex = /problem path:.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('problem path:.+', 'gm')
const str = `here is one line
problem path: path1
another line
value line more info
value
problem path: path2
incredible data line
problem path: path3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}