import re
regex = re.compile(r"problem path:.+", flags=re.MULTILINE)
test_str = ("here is one line\n"
"problem path: path1\n"
"another line\n"
"value line more info\n"
"value\n"
"problem path: path2\n"
"incredible data line\n"
"problem path: path3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")